Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public virtual TableHitTestInfo Select(
Point3d pickingPoint,
Vector3d hitTestViewDirection,
Vector3d hitTestViewOrientation,
bool allowOutside,
bool inPickFirst,
FullSubentityPath[] paths
)
Public Overridable Function Select (
pickingPoint As Point3d,
hitTestViewDirection As Vector3d,
hitTestViewOrientation As Vector3d,
allowOutside As Boolean,
inPickFirst As Boolean,
paths As FullSubentityPath()
) As TableHitTestInfo
public:
virtual TableHitTestInfo Select(
Point3d pickingPoint,
Vector3d hitTestViewDirection,
Vector3d hitTestViewOrientation,
bool allowOutside,
bool inPickFirst,
array<FullSubentityPath>^ paths
)
abstract Select :
pickingPoint : Point3d *
hitTestViewDirection : Vector3d *
hitTestViewOrientation : Vector3d *
allowOutside : bool *
inPickFirst : bool *
paths : FullSubentityPath[] -> TableHitTestInfo
override Select :
pickingPoint : Point3d *
hitTestViewDirection : Vector3d *
hitTestViewOrientation : Vector3d *
allowOutside : bool *
inPickFirst : bool *
paths : FullSubentityPath[] -> TableHitTestInfo
Parameters
- pickingPoint
- Type: Teigha.GeometryPoint3d
- hitTestViewDirection
- Type: Teigha.GeometryVector3d
- hitTestViewOrientation
- Type: Teigha.GeometryVector3d
- allowOutside
- Type: SystemBoolean
- inPickFirst
- Type: SystemBoolean
- paths
- Type: Teigha.DatabaseServicesFullSubentityPath
Return Value
Type:
TableHitTestInfo
See Also