Table Class

Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public class Table : BlockReference

The Table type exposes the following members.

Constructors
  Name Description
Public method Table
Initializes a new instance of the Table class
Protected method Table(IntPtr, Boolean)
Initializes a new instance of the Table class
Top
Properties
  Name Description
Public property BreakEnabled
Public property BreakFlowDirection
Public property BreakOptions
Public property Cells
Public property Columns
Public property Direction
Public property FlowDirection
Public property HasSubSelection
Public property Height
Public property HorizontalCellMargin
Public property IsHeaderSuppressed Obsolete.
Public property IsTitleSuppressed Obsolete.
Public property MinimumTableHeight
Public property MinimumTableWidth
Public property NumColumns Obsolete.
Public property NumRows Obsolete.
Public property Rows
Public property SubSelection
Public property TableStyle
Public property TableStyleName
Public property VerticalCellMargin
Public property Width
Top
Methods
  Name Description
Public method Alignment(RowType)
Public method Alignment(Int32, Int32)
Public method AttachmentPoint
Public method BackgroundColor(RowType)
Public method BackgroundColor(Int32, Int32)
Public method BlockRotation
Public method BlockScale
Public method BlockTableRecordId
Public method CanDeleteColumns
Public method CanDeleteRows
Public method CanInsertColumn
Public method CanInsertRow
Public method CellStyleOverrides
Public method CellType
Public method ClearSubSelection
Public method ClearTableStyleOverrides
Public method ColumnWidth
Public method ContentColor(RowType)
Public method ContentColor(Int32, Int32)
Public method CopyFrom(LinkedTableData, TableCopyOptions)
Public method CopyFrom(CellRange, LinkedTableData, TableCopyOptions, CellRange, CellRange)
Public method CopyFrom(CellRange, Table, TableCopyOptions, CellRange, CellRange)
Public method CreateContent
Public method DataType(RowType)
Public method DataType(Int32, Int32)
Public method DeleteCellContent
Public method DeleteColumns
Public method DeleteContent(CellRange)
Public method DeleteContent(Int32, Int32)
Public method DeleteContent(Int32, Int32, Int32)
Public method DeleteRows
Public method FieldId
Public method Fill
Public method Format(RowType)
Public method Format(Int32, Int32)
Public method GenerateLayout
Public method GetBlockAttributeValue(Int32, Int32, ObjectId)
Public method GetBlockAttributeValue(Int32, Int32, Int32, ObjectId)
Public method GetBlockTableRecordId
Public method GetBreakHeight
Public method GetBreakOffset
Public method GetBreakSpacing
Public method GetCellExtents
Public method GetCellState
Public method GetCellStyle
Public method GetColumnName
Public method GetContentColor
Public method GetContentLayout
Public method GetContentTypes(Int32, Int32)
Public method GetContentTypes(Int32, Int32, Int32)
Public method GetCustomData(Int32, Int32)
Public method GetCustomData(Int32, Int32, String)
Public method GetDataFormat(Int32, Int32)
Public method GetDataFormat(Int32, Int32, Int32)
Public method GetDataLink
Public method GetDataLink(CellRange)
Public method GetDataLink(Int32, Int32)
Public method GetDataLinkRange
Public method GetDataType
Public method GetFieldId
Public method GetFormula
Public method GetGridColor
Public method GetGridDoubleLineSpacing
Public method GetGridLineStyle
Public method GetGridLinetype
Public method GetGridLineWeight
Public method GetGridProperty
Public method GetGridVisibility
Public method GetIsAutoScale
Public method GetMargin
Public method GetMergeAllEnabled
Public method GetMergeRange
Public method GetNumberOfContents
Public method GetOverrides(Int32, Int32, Int32)
Public method GetOverrides(Int32, Int32, GridLineType)
Public method GetRotation
Public method GetScale
Public method GetTextHeight
Public method GetTextString(Int32, Int32, Int32)
Public method GetTextString(Int32, Int32, Int32, FormatOption)
Public method GetTextStyleId
Public method GetToolTip
Public method GetValue(Int32, Int32, Int32)
Public method GetValue(Int32, Int32, Int32, FormatOption)
Public method GridColor(GridLineType, RowType)
Public method GridColor(Int32, Int32, CellEdgeMasks)
Public method GridLineWeight(GridLineType, RowType)
Public method GridLineWeight(Int32, Int32, CellEdgeMasks)
Public method GridVisibility(GridLineType, RowType)
Public method GridVisibility(Int32, Int32, CellEdgeMasks)
Public method HasFormula
Public method HitTest
Public method InsertColumns
Public method InsertColumnsAndInherit
Public method InsertRows
Public method InsertRowsAndInherit
Public method IsAutoScale
Public method IsBackgroundColorNone(RowType)
Public method IsBackgroundColorNone(Int32, Int32)
Public method IsContentEditable
Public method IsEmpty
Public method IsFormatEditable
Public method IsLinked
Public method IsMergedCell
Public method MergeCells
Public method MinimumColumnWidth
Public method MinimumRowHeight
Public method MoveContent
Public method RecomputeTableBlock
Public method RemoveAllOverrides
Public method RemoveDataLink
Public method RemoveDataLink(Int32, Int32)
Public method ReselectSubRegion
Public method ResetValue
Public method RowHeight
Public method RowType
Public method Select
Public method SelectSubRegion
Public method SetAlignment(CellAlignment, Int32)
Public method SetAlignment(Int32, Int32, CellAlignment)
Public method SetAutoScale
Public method SetBackgroundColor(Color, Int32)
Public method SetBackgroundColor(Int32, Int32, Color)
Public method SetBackgroundColorNone(Boolean, Int32)
Public method SetBackgroundColorNone(Int32, Int32, Boolean)
Public method SetBlockAttributeValue(Int32, Int32, ObjectId, String)
Public method SetBlockAttributeValue(Int32, Int32, Int32, ObjectId, String)
Public method SetBlockRotation
Public method SetBlockScale
Public method SetBlockTableRecordId(Int32, Int32, ObjectId, Boolean)
Public method SetBlockTableRecordId(Int32, Int32, Int32, ObjectId, Boolean)
Public method SetBreakHeight
Public method SetBreakOffset
Public method SetBreakSpacing
Public method SetCellState
Public method SetCellStyle
Public method SetCellType
Public method SetColumnName
Public method SetColumnWidth(Double)
Public method SetColumnWidth(Int32, Double)
Public method SetContentColor(Color, Int32)
Public method SetContentColor(Int32, Int32, Color)
Public method SetContentColor(Int32, Int32, Int32, Color)
Public method SetContentLayout
Public method SetCustomData(Int32, Int32, Int32)
Public method SetCustomData(Int32, Int32, String, Object)
Public method SetDataFormat(Int32, Int32, String)
Public method SetDataFormat(Int32, Int32, Int32, String)
Public method SetDataLink(CellRange, ObjectId, Boolean)
Public method SetDataLink(Int32, Int32, ObjectId, Boolean)
Public method SetDataType(DataType, UnitType, Int32)
Public method SetDataType(Int32, Int32, Int32, DataTypeParameter)
Public method SetDataType(Int32, Int32, DataType, UnitType)
Public method SetFieldId(Int32, Int32, ObjectId)
Public method SetFieldId(Int32, Int32, Int32, ObjectId, CellOption)
Public method SetFormat(String, Int32)
Public method SetFormat(Int32, Int32, String)
Public method SetFormula
Public method SetGridColor(Color, Int32, Int32)
Public method SetGridColor(Int32, Int32, Int16, Color)
Public method SetGridColor(Int32, Int32, GridLineType, Color)
Public method SetGridDoubleLineSpacing
Public method SetGridLineStyle
Public method SetGridLinetype
Public method SetGridLineWeight(LineWeight, Int32, Int32)
Public method SetGridLineWeight(Int32, Int32, Int16, LineWeight)
Public method SetGridLineWeight(Int32, Int32, GridLineType, LineWeight)
Public method SetGridProperty(CellRange, GridLineType, GridPropertyParameter)
Public method SetGridProperty(Int32, Int32, GridLineType, GridPropertyParameter)
Public method SetGridVisibility(Boolean, Int32, Int32)
Public method SetGridVisibility(Int32, Int32, Int16, Boolean)
Public method SetGridVisibility(Int32, Int32, GridLineType, Visibility)
Public method SetIsAutoScale
Public method SetMargin
Public method SetMergeAllEnabled
Public method SetOverrides(Int32, Int32, Int32, CellProperties)
Public method SetOverrides(Int32, Int32, GridLineType, CellProperties)
Public method SetRotation
Public method SetRowHeight(Double)
Public method SetRowHeight(Int32, Double)
Public method SetScale
Public method SetSize
Public method SetTextHeight(Double, Int32)
Public method SetTextHeight(Int32, Int32, Double)
Public method SetTextHeight(Int32, Int32, Int32, Double)
Public method SetTextRotation
Public method SetTextString(Int32, Int32, String)
Public method SetTextString(Int32, Int32, Int32, String)
Public method SetTextStyle(ObjectId, Int32)
Public method SetTextStyle(Int32, Int32, ObjectId)
Public method SetTextStyleId
Public method SetToolTip
Public method SetValue(Int32, Int32, Object)
Public method SetValue(Int32, Int32, Int32, Object)
Public method SetValue(Int32, Int32, String, ParseOption)
Public method SetValue(Int32, Int32, Int32, Object, ParseOption)
Public method SetValue(Int32, Int32, Int32, String, ParseOption)
Public method SuppressRegenerateTable
Public method TableStyleOverrides
Public method TextHeight(RowType)
Public method TextHeight(Int32, Int32)
Public method TextRotation
Public method TextString(Int32, Int32)
Public method TextString(Int32, Int32, FormatOption)
Public method TextStringConst
Public method TextStyle(RowType)
Public method TextStyle(Int32, Int32)
Public method UnitType(RowType)
Public method UnitType(Int32, Int32)
Public method UnmergeCells
Public method UpdateDataLink(UpdateDirection, UpdateOption)
Public method UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption)
Public method Value
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.