Retrieves the 2D vector, in the coordinate
system of the plane, corresponding to the 3D vector.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Vector2d Convert2d(
PlanarEntity plane
)
Public Function Convert2d (
plane As PlanarEntity
) As Vector2d
public:
Vector2d Convert2d(
PlanarEntity^ plane
)
member Convert2d :
plane : PlanarEntity -> Vector2d
Parameters
- plane
- Type: Teigha.GeometryPlanarEntity
[in] Any 3D plane. If no plane is specified, the XY plane is
used.
Return Value
Type:
Vector2d
2D vector, in the coordinate system of the plane, corresponding to
the 3D vector.
Remarks
The 3D vector
must be parallel to the plane.
See Also