CoordinateSystem3d Constructor

Constructor for the CoordinateSystem3d structure.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public CoordinateSystem3d(
        Point3d o,
        Vector3d x,
        Vector3d y
)

Parameters

o
Type: Teigha.GeometryPoint3d
[in] Coordinate system origin.
x
Type: Teigha.GeometryVector3d
[in] Defines the positive direction of the x-axis of this system.
y
Type: Teigha.GeometryVector3d
[in] Defines the positive direction of the y-axis of this system.
Remarks
The z-axis is calculated as x.CrossProduct(y).
See Also

©  Bricsys NV. All rights reserved.