Curve3dIsCoplanarWith Method (Curve3d, Plane)
|
Checks whether the specified curve entity is
coplanar with this curve and returns the common plane.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public bool IsCoplanarWith(
Curve3d curve3d,
out Plane plane
)
Public Function IsCoplanarWith (
curve3d As Curve3d,
<OutAttribute> ByRef plane As Plane
) As Boolean
public:
bool IsCoplanarWith(
Curve3d^ curve3d,
[OutAttribute] Plane^% plane
)
member IsCoplanarWith :
curve3d : Curve3d *
plane : Plane byref -> bool
Parameters
- curve3d
- Type: Teigha.GeometryCurve3d
[in] Curve to be checked.
- plane
- Type: Teigha.GeometryPlane
[out] Receives the common plane of the curves.
Return Value
Type:
Boolean
true if the specified curve is coplanar
with this curve,
false otherwise.
See Also