Plane Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class Plane : PlanarEntity

The Plane type exposes the following members.

Constructors
  Name Description
Public method Plane
Initializes a new instance of the Plane class
Public method Plane(Plane)
Initializes a new instance of the Plane class
Public method Plane(Point3d, Vector3d)
Initializes a new instance of the Plane class
Public method Plane(Point3d, Point3d, Point3d)
Initializes a new instance of the Plane class
Public method Plane(Point3d, Vector3d, Vector3d)
Initializes a new instance of the Plane class
Public method Plane(Double, Double, Double, Double)
Initializes a new instance of the Plane class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public methodStatic member Create
Public method GetSignedDistanceTo
Public method IntersectWith(BoundedPlane)
Public method IntersectWith(Plane)
Public method IntersectWith(BoundedPlane, Tolerance)
Public method IntersectWith(Plane, Tolerance)
Public method Set(Point3d, Vector3d)
Public method Set(Point3d, Point3d, Point3d)
Public method Set(Point3d, Vector3d, Vector3d)
Public method Set(Double, Double, Double, Double)
Top
See Also

©  Bricsys NV. All rights reserved.