Vector3d Constructor (PlanarEntity, Vector2d)
|
Constructor for the Vector3d class. Creates a
new vector in the coordinates of the plane: uAxis * vect.x + vAxis
* vect.y where uAxis and vAxis are returned by plane.get(origin,
uAxis, vAxis).
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Vector3d(
PlanarEntity plane,
Vector2d vector2d
)
Public Sub New (
plane As PlanarEntity,
vector2d As Vector2d
)
public:
Vector3d(
PlanarEntity^ plane,
Vector2d vector2d
)
new :
plane : PlanarEntity *
vector2d : Vector2d -> Vector3d
Parameters
- plane
- Type: Teigha.GeometryPlanarEntity
[in] 2D plane.[in] 2D vector.
- vector2d
- Type: Teigha.GeometryVector2d
See Also