BlockTableRecordGetBlockReferenceIds Method
|
Returns the Object IDs of all BlockReference
entities that reference this block.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public ObjectIdCollection GetBlockReferenceIds(
bool directOnly,
bool forceValidity
)
Public Function GetBlockReferenceIds (
directOnly As Boolean,
forceValidity As Boolean
) As ObjectIdCollection
public:
ObjectIdCollection^ GetBlockReferenceIds(
bool directOnly,
bool forceValidity
)
member GetBlockReferenceIds :
directOnly : bool *
forceValidity : bool -> ObjectIdCollection
Parameters
- directOnly
- Type: SystemBoolean
If true, returns only direct references.
- forceValidity
- Type: SystemBoolean
If true, forces the loading of partially loaded drawings.
Return Value
Type:
ObjectIdCollection
The ObjectIdCollection object.
Remarks
If this block is
nested, references to the parent block(s) will be included if and
only if directOnly is false. Older drawings do not explicitly store
this information, and hence must be completely loaded.
See Also