BlockTableRecord Class

Wraps the OdDbBlockTableRecord class. BlockTableRecord objects represent containers for entities in a drawing file: all entities are owned by blocks which are stored in the block table as block table records.
Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public class BlockTableRecord : SymbolTableRecord, 
        IEnumerable

The BlockTableRecord type exposes the following members.

Constructors
  Name Description
Public method BlockTableRecord
Default constructor.
Protected method BlockTableRecord(IntPtr, Boolean)
Initializes a new instance of the BlockTableRecord class
Top
Properties
  Name Description
Public property BlockBeginId
Gets the BlockBegin object.
Public property BlockEndId
Gets the BlockEnd object.
Public property BlockScaling
Gets or sets the scaling characteristics (uniform or non-uniform) of block references associated with this block table record.
Public property Comments
Gets or sets the description text associated with this block.
Public property DrawOrderTableId
Gets the id of a DrawOrderTable object associated with this block.
Public property Explodable
Gets or sets whether references to this block can be exploded.
Public property HasAttributeDefinitions
Gets whether this block table record has attribute definitions.
Public property HasPreviewIcon
Gets whether this block table record has preview icon.
Public property IncludingErased
Gets the copy of this BlockTableRecord object which includes erased Entity objects also.
Public property IsAnonymous
Gets whether this block table record is anonymous.
Public property IsDynamicBlock
Gets whether this block table record is a dynamic block.
Public property IsFromExternalReference
Gets whether this block table record is an Xref.
Public property IsFromOverlayReference
Gets or sets whether this block table record is an overlaid Xref.
Public property IsLayout
Gets whether this block table record represents a layout.
Public property IsUnloaded
Gets or sets whether this block table record is unloaded Xref.
Public property LayoutId
Gets or sets the id of the Layout associated with this block table record.
Public property Origin
Gets or sets the WCS origin (the insertion point) of this block table record.
Public property PathName
Gets or sets the path and filename for the Xref drawing.
Public property PreviewIcon
Gets or sets the preview icon associated with this block table record.
Protected property SkipDeleted
Public property Units
Gets or sets the block insertion units for this block table record.
Public property XrefStatus
Gets the Xref status of this block table record.
Top
Methods
  Name Description
Public method AppendEntity
Appends the specified Entity object to this block table record.
Public method AssumeOwnershipOf
This method causes the invoked block table record to assume the ownership of all the entities listed in the input array, and provides an optimized way of moving entities between block table records.
Protected method Copy
Public method GetAnonymousBlockIds
Currently not implemented.
Public method GetBlockReferenceIds
Returns the Object IDs of all BlockReference entities that reference this block.
Public method GetEnumerator
Returns an enumerator that iterates through the collection.
Public method GetErasedBlockReferenceIds
Returns the Object ID's of all erased BlockReference entities that directly reference this block.
Public method GetXrefDatabase
Returns the database that defines this Xref.
Protected method IEnumerable_GetEnumerator
Public method UpdateAnonymousBlocks
Updates the anonymous blocks created from this dynamic block definition to reflect any changes made to the dynamic block definition.
Top
Events
  Name Description
Public eventStatic member BlockInsertionPoints
Occurs during the insertion of a block for which insertion points are defined.
Top
Fields
  Name Description
Public fieldStatic member ModelSpace
Represents the modelspace block.
Public fieldStatic member PaperSpace
Represents the paperspace block.
Top
See Also

©  Bricsys NV. All rights reserved.