GeometryCircularArc Method (Point3d, Double, Vector3d, Vector3d,
Double, ArcType)
|
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public abstract bool CircularArc(
Point3d center,
double radius,
Vector3d normal,
Vector3d startVector,
double sweepAngle,
ArcType arcType
)
Public MustOverride Function CircularArc (
center As Point3d,
radius As Double,
normal As Vector3d,
startVector As Vector3d,
sweepAngle As Double,
arcType As ArcType
) As Boolean
public:
virtual bool CircularArc(
Point3d center,
double radius,
Vector3d normal,
Vector3d startVector,
double sweepAngle,
ArcType arcType
) abstract
abstract CircularArc :
center : Point3d *
radius : float *
normal : Vector3d *
startVector : Vector3d *
sweepAngle : float *
arcType : ArcType -> bool
Parameters
- center
- Type: Teigha.GeometryPoint3d
- radius
- Type: SystemDouble
- normal
- Type: Teigha.GeometryVector3d
- startVector
- Type: Teigha.GeometryVector3d
- sweepAngle
- Type: SystemDouble
- arcType
- Type: Teigha.GraphicsInterfaceArcType
Return Value
Type:
Boolean
See Also