|
Name |
Description |
|
Circle(Point3d, Double,
Vector3d)
|
|
|
Circle(Point3d, Point3d,
Point3d)
|
|
|
CircularArc(Point3d,
Point3d, Point3d, ArcType)
|
|
|
CircularArc(Point3d,
Double, Vector3d, Vector3d, Double, ArcType)
|
|
|
Clone
|
(Inherited from RXObject.) |
|
CompareTo
|
(Inherited from RXObject.) |
|
CopyFrom
|
(Inherited from RXObject.) |
|
CreateObjRef
|
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
|
DeleteUnmanagedObject
|
(Inherited from RXObject.) |
|
Dispose
|
(Inherited from DisposableWrapper.) |
|
Dispose(Boolean)
|
(Inherited from DisposableWrapper.) |
|
Draw
|
|
|
EllipticalArc
|
|
|
Equals
|
(Inherited from DisposableWrapper.) |
|
Finalize
|
(Inherited from DisposableWrapper.) |
|
GetHashCode
|
(Inherited from DisposableWrapper.) |
|
GetLifetimeService
|
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
|
GetRXClass
|
(Inherited from RXObject.) |
|
GetType
|
Gets the Type of the current instance.
(Inherited from Object.) |
|
Image(ImageBGRA32,
Point3d, Vector3d, Vector3d)
|
|
|
Image(ImageBGRA32,
Point3d, Vector3d, Vector3d, TransparencyMode)
|
|
|
InitializeLifetimeService
|
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
|
MemberwiseClone
|
Creates a shallow copy of the current Object.
(Inherited from Object.) |
|
MemberwiseClone(Boolean)
|
(Inherited from MarshalByRefObject.) |
|
Mesh
|
|
|
OwnerDraw
|
|
|
Polygon
|
|
|
Polyline(Polyline)
|
|
|
Polyline(Point3dCollection,
Vector3d, IntPtr)
|
|
|
Polyline(Polyline,
Int32, Int32)
|
|
|
Polypoint(Point3dCollection,
Vector3dCollection, IntPtrCollection)
|
|
|
Polypoint(Point3dCollection,
EntityColorCollection, Vector3dCollection, IntPtrCollection)
|
|
|
Polypoint(Point3dCollection,
EntityColorCollection, TransparencyCollection, Vector3dCollection,
IntPtrCollection, Int32)
|
|
|
PolyPolygon
|
|
|
PolyPolyline
|
|
|
PopClipBoundary
|
|
|
PopModelTransform
|
|
|
PushClipBoundary(ClipBoundary)
|
|
|
PushClipBoundary(ClipBoundary,
AbstractClipBoundary)
|
|
|
PushModelTransform(Matrix3d)
|
|
|
PushModelTransform(Vector3d)
|
|
|
PushOrientationTransform
|
|
|
PushPositionTransform(PositionBehavior,
Point2d)
|
|
|
PushPositionTransform(PositionBehavior,
Point3d)
|
|
|
PushScaleTransform(ScaleBehavior,
Point2d)
|
|
|
PushScaleTransform(ScaleBehavior,
Point3d)
|
|
|
QueryX
|
(Inherited from RXObject.) |
|
Ray
|
|
|
RowOfDots
|
|
|
Shell
|
|
|
Text(Point3d, Vector3d,
Vector3d, String, Boolean, TextStyle)
|
|
|
Text(Point3d, Vector3d,
Vector3d, Double, Double, Double, String)
|
|
|
ToString
|
Returns a string that represents the current
object.
(Inherited from Object.) |
|
WorldLine
|
|
|
X
|
(Inherited from RXObject.) |
|
Xline
|
|