GeometryEllipticalArc Method
|
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public abstract bool EllipticalArc(
Point3d center,
Vector3d normal,
double majorAxisLength,
double minorAxisLength,
double startDegreeInRads,
double endDegreeInRads,
double tiltDegreeInRads,
ArcType arType
)
Public MustOverride Function EllipticalArc (
center As Point3d,
normal As Vector3d,
majorAxisLength As Double,
minorAxisLength As Double,
startDegreeInRads As Double,
endDegreeInRads As Double,
tiltDegreeInRads As Double,
arType As ArcType
) As Boolean
public:
virtual bool EllipticalArc(
Point3d center,
Vector3d normal,
double majorAxisLength,
double minorAxisLength,
double startDegreeInRads,
double endDegreeInRads,
double tiltDegreeInRads,
ArcType arType
) abstract
abstract EllipticalArc :
center : Point3d *
normal : Vector3d *
majorAxisLength : float *
minorAxisLength : float *
startDegreeInRads : float *
endDegreeInRads : float *
tiltDegreeInRads : float *
arType : ArcType -> bool
Parameters
- center
- Type: Teigha.GeometryPoint3d
- normal
- Type: Teigha.GeometryVector3d
- majorAxisLength
- Type: SystemDouble
- minorAxisLength
- Type: SystemDouble
- startDegreeInRads
- Type: SystemDouble
- endDegreeInRads
- Type: SystemDouble
- tiltDegreeInRads
- Type: SystemDouble
- arType
- Type: Teigha.GraphicsInterfaceArcType
Return Value
Type:
Boolean
See Also