AbstractViewPESetView Method (Point3d, Vector3d, Vector3d, Double,
Double, Boolean, Vector2d)
|
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void SetView(
Point3d target,
Vector3d direction,
Vector3d upVector,
double fieldWidth,
double fieldHeight,
bool isPerspective,
Vector2d viewOffset
)
Public Sub SetView (
target As Point3d,
direction As Vector3d,
upVector As Vector3d,
fieldWidth As Double,
fieldHeight As Double,
isPerspective As Boolean,
viewOffset As Vector2d
)
public:
void SetView(
Point3d target,
Vector3d direction,
Vector3d upVector,
double fieldWidth,
double fieldHeight,
bool isPerspective,
Vector2d viewOffset
)
member SetView :
target : Point3d *
direction : Vector3d *
upVector : Vector3d *
fieldWidth : float *
fieldHeight : float *
isPerspective : bool *
viewOffset : Vector2d -> unit
Parameters
- target
- Type: Teigha.GeometryPoint3d
- direction
- Type: Teigha.GeometryVector3d
- upVector
- Type: Teigha.GeometryVector3d
- fieldWidth
- Type: SystemDouble
- fieldHeight
- Type: SystemDouble
- isPerspective
- Type: SystemBoolean
- viewOffset
- Type: Teigha.GeometryVector2d
See Also