AbstractViewPE Class |
The AbstractViewPE type exposes the following members.
Name | Description | |
---|---|---|
![]() |
AbstractViewPE |
Initializes a new instance of the AbstractViewPE class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
BackClipDistance | |
![]() |
Direction | |
![]() |
Elevation | |
![]() |
EyeToWorld | |
![]() |
FieldHeight | |
![]() |
FieldWidth | |
![]() |
FrontClipDistance | |
![]() |
FrozenLayers | |
![]() |
HasUcs | |
![]() |
HasViewOffset | |
![]() |
HasViewport | |
![]() |
IsBackClipOn | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
IsFrontClipAtEyeOn | |
![]() |
IsFrontClipOn | |
![]() |
IsPerspective | |
![]() |
IsPlotting | |
![]() |
LensLength | |
![]() |
LowerLeftCorner | |
![]() |
OrthoUcs | |
![]() |
RenderMode | |
![]() |
Target | |
![]() |
Ucs | |
![]() |
UcsName | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
![]() |
UpperRightCorner | |
![]() |
UpVector | |
![]() |
ViewOffset | |
![]() |
ViewTwist | |
![]() |
VisualStyle | |
![]() |
WorldToEye |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from RXObject.) |
![]() |
CompareTo | (Inherited from RXObject.) |
![]() |
CopyFrom | (Inherited from RXObject.) |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() ![]() |
GetClass | |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetPlotExtents | |
![]() |
GetRXClass | (Inherited from RXObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
GetViewExtents | |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
QueryX | (Inherited from RXObject.) |
![]() |
SetUcsFromView | |
![]() |
SetView(RXObject) | |
![]() |
SetView(Point3d, Vector3d, Vector3d, Double, Double, Boolean, Vector2d) | |
![]() |
SetViewport | |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
X | (Inherited from RXObject.) |
![]() |
ZoomExtents | |
![]() |
ZoomExtents(BoundBlock3d) | |
![]() |
ZoomExtents(BoundBlock3d, Double) |
© Bricsys NV. All rights reserved. |