Curve3dGetTrimmedOffset Method (Double, Vector3d, OffsetCurveExtensionType)

Receives one or more offset curves that represent the trimmed offset of the curve.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public Curve3d[] GetTrimmedOffset(
        double distance,
        Vector3d planeNormal,
        OffsetCurveExtensionType extensionType
)

Parameters

distance
Type: SystemDouble
[in] Offset distance.
planeNormal
Type: Teigha.GeometryVector3d
[in] A normal to the plane of this curve.
extensionType
Type: Teigha.GeometryOffsetCurveExtensionType
[in] Determines how the offset curve will be extended at points of C1 discontinuity.

Return Value

Type: Curve3d
Array that stores offset curves.
See Also

©  Bricsys NV. All rights reserved.