ViewportGeometryDeviceContextRasterImage Method
|
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public abstract bool DeviceContextRasterImage(
Point3d origin,
Vector3d u,
Vector3d v,
Matrix2d pixel,
ObjectId entityId,
ImageOrg imageOrg,
int imageWidth,
int imageHeight,
short imageColorDepth,
bool transparency,
ImageSource source,
Vector3d unRotated,
ImageOrg originalImage,
Matrix2d unRotatedPixel,
int unRotatedImageWidth,
int unRotatedImageHeight
)
Public MustOverride Function DeviceContextRasterImage (
origin As Point3d,
u As Vector3d,
v As Vector3d,
pixel As Matrix2d,
entityId As ObjectId,
imageOrg As ImageOrg,
imageWidth As Integer,
imageHeight As Integer,
imageColorDepth As Short,
transparency As Boolean,
source As ImageSource,
unRotated As Vector3d,
originalImage As ImageOrg,
unRotatedPixel As Matrix2d,
unRotatedImageWidth As Integer,
unRotatedImageHeight As Integer
) As Boolean
public:
virtual bool DeviceContextRasterImage(
Point3d origin,
Vector3d u,
Vector3d v,
Matrix2d pixel,
ObjectId entityId,
ImageOrg imageOrg,
int imageWidth,
int imageHeight,
short imageColorDepth,
bool transparency,
ImageSource source,
Vector3d unRotated,
ImageOrg originalImage,
Matrix2d unRotatedPixel,
int unRotatedImageWidth,
int unRotatedImageHeight
) abstract
abstract DeviceContextRasterImage :
origin : Point3d *
u : Vector3d *
v : Vector3d *
pixel : Matrix2d *
entityId : ObjectId *
imageOrg : ImageOrg *
imageWidth : int *
imageHeight : int *
imageColorDepth : int16 *
transparency : bool *
source : ImageSource *
unRotated : Vector3d *
originalImage : ImageOrg *
unRotatedPixel : Matrix2d *
unRotatedImageWidth : int *
unRotatedImageHeight : int -> bool
Parameters
- origin
- Type: Teigha.GeometryPoint3d
- u
- Type: Teigha.GeometryVector3d
- v
- Type: Teigha.GeometryVector3d
- pixel
- Type: Teigha.GeometryMatrix2d
- entityId
- Type: Teigha.DatabaseServicesObjectId
- imageOrg
- Type: Teigha.GraphicsInterfaceImageOrg
- imageWidth
- Type: SystemInt32
- imageHeight
- Type: SystemInt32
- imageColorDepth
- Type: SystemInt16
- transparency
- Type: SystemBoolean
- source
- Type: Teigha.GraphicsInterfaceImageSource
- unRotated
- Type: Teigha.GeometryVector3d
- originalImage
- Type: Teigha.GraphicsInterfaceImageOrg
- unRotatedPixel
- Type: Teigha.GeometryMatrix2d
- unRotatedImageWidth
- Type: SystemInt32
- unRotatedImageHeight
- Type: SystemInt32
Return Value
Type:
Boolean
See Also