EdgeRef Constructor (CompoundObjectId, SubentityId, SubentityId, Curve3d)

Constructor for the EdgeRef class. Creates an edge reference based on the specified full sub-entity path.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public EdgeRef(
        CompoundObjectId compoundObjectId,
        SubentityId edgeSubentId,
        SubentityId faceSubentId,
        Curve3d curve
)

Parameters

compoundObjectId
Type: Teigha.DatabaseServicesCompoundObjectId
[in] Identifier of the compound object that is the base of this edge reference.
edgeSubentId
Type: Teigha.DatabaseServicesSubentityId
[in] Edge sub-entity.
faceSubentId
Type: Teigha.DatabaseServicesSubentityId
[in] Face sub-entity.
curve
Type: Teigha.GeometryCurve3d
[in] Curve that is the base of this edge reference.
See Also

©  Bricsys NV. All rights reserved.