Curve3dGetClosestPointTo Method (Curve3d)

Retrieves the closest points between this curve and the passed curve.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public PointOnCurve3d[] GetClosestPointTo(
        Curve3d curve3d
)

Parameters

curve3d
Type: Teigha.GeometryCurve3d
[in] Curve to which closest points are calculated.

Return Value

Type: PointOnCurve3d
Array of closest points. The point with index 0 is the closest point on this curve; the point with index 1 is the closest point on the other curve.
See Also

©  Bricsys NV. All rights reserved.