PointOnCurve3d Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class PointOnCurve3d : PointEntity3d

The PointOnCurve3d type exposes the following members.

Constructors
  Name Description
Public method PointOnCurve3d
Initializes a new instance of the PointOnCurve3d class
Public method PointOnCurve3d(Curve3d, Double)
Initializes a new instance of the PointOnCurve3d class
Top
Properties
  Name Description
Public property Curve
Public property Parameter
Public property Point
Top
Methods
  Name Description
Public methodStatic member Create
Public method GetCurvature
Public method GetCurvature(Double)
Public method GetDerivative(Int32)
Public method GetDerivative(Int32, Double)
Public methodStatic member GetDerivative(Int32, Curve3d, Double)
Public method GetPointAtParameter
Public methodStatic member GetPointOnCurve
Public method IsSingular
Public method IsSingular(Tolerance)
Top
See Also

©  Bricsys NV. All rights reserved.