Curve3dGetClosestPointTo Method (Curve3d, Tolerance)
|
Retrieves the closest points between this
curve and the passed curve within a specified tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public PointOnCurve3d[] GetClosestPointTo(
Curve3d curve3d,
Tolerance tolerance
)
Public Function GetClosestPointTo (
curve3d As Curve3d,
tolerance As Tolerance
) As PointOnCurve3d()
public:
array<PointOnCurve3d^>^ GetClosestPointTo(
Curve3d^ curve3d,
Tolerance tolerance
)
member GetClosestPointTo :
curve3d : Curve3d *
tolerance : Tolerance -> PointOnCurve3d[]
Parameters
- curve3d
- Type: Teigha.GeometryCurve3d
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
PointOnCurve3d
Array of closest points. The point with index 0 is the closest
point on this curve; the point with index 1 is the closest point on
the other curve.
See Also