NurbCurve3dSetFitData Method (KnotCollection, Point3dCollection,
Vector3d, Vector3d, Boolean)
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void SetFitData(
KnotCollection fitKnots,
Point3dCollection fitPoints,
Vector3d startTangent,
Vector3d endTangent,
bool periodic
)
Public Sub SetFitData (
fitKnots As KnotCollection,
fitPoints As Point3dCollection,
startTangent As Vector3d,
endTangent As Vector3d,
periodic As Boolean
)
public:
void SetFitData(
KnotCollection^ fitKnots,
Point3dCollection^ fitPoints,
Vector3d startTangent,
Vector3d endTangent,
bool periodic
)
member SetFitData :
fitKnots : KnotCollection *
fitPoints : Point3dCollection *
startTangent : Vector3d *
endTangent : Vector3d *
periodic : bool -> unit
Parameters
- fitKnots
- Type: Teigha.GeometryKnotCollection
- fitPoints
- Type: Teigha.GeometryPoint3dCollection
- startTangent
- Type: Teigha.GeometryVector3d
- endTangent
- Type: Teigha.GeometryVector3d
- periodic
- Type: SystemBoolean
See Also