GeometryOverruleIntersectWith Method (Entity, Entity, Intersect, Plane,
Point3dCollection, IntPtr, IntPtr)
|
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public virtual void IntersectWith(
Entity entity,
Entity ent,
Intersect intType,
Plane projPlane,
Point3dCollection points,
IntPtr thisGsMarker,
IntPtr otherGsMarker
)
Public Overridable Sub IntersectWith (
entity As Entity,
ent As Entity,
intType As Intersect,
projPlane As Plane,
points As Point3dCollection,
thisGsMarker As IntPtr,
otherGsMarker As IntPtr
)
public:
virtual void IntersectWith(
Entity^ entity,
Entity^ ent,
Intersect intType,
Plane^ projPlane,
Point3dCollection^ points,
IntPtr thisGsMarker,
IntPtr otherGsMarker
)
abstract IntersectWith :
entity : Entity *
ent : Entity *
intType : Intersect *
projPlane : Plane *
points : Point3dCollection *
thisGsMarker : IntPtr *
otherGsMarker : IntPtr -> unit
override IntersectWith :
entity : Entity *
ent : Entity *
intType : Intersect *
projPlane : Plane *
points : Point3dCollection *
thisGsMarker : IntPtr *
otherGsMarker : IntPtr -> unit
Parameters
- entity
- Type: Teigha.DatabaseServicesEntity
- ent
- Type: Teigha.DatabaseServicesEntity
- intType
- Type: Teigha.DatabaseServicesIntersect
- projPlane
- Type: Teigha.GeometryPlane
- points
- Type: Teigha.GeometryPoint3dCollection
- thisGsMarker
- Type: SystemIntPtr
- otherGsMarker
- Type: SystemIntPtr
See Also