OffsetCurve3d Constructor
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public OffsetCurve3d(
Curve3d baseCurve,
Vector3d planeNormal,
double offsetDistance
)
Public Sub New (
baseCurve As Curve3d,
planeNormal As Vector3d,
offsetDistance As Double
)
public:
OffsetCurve3d(
Curve3d^ baseCurve,
Vector3d planeNormal,
double offsetDistance
)
new :
baseCurve : Curve3d *
planeNormal : Vector3d *
offsetDistance : float -> OffsetCurve3d
Parameters
- baseCurve
- Type: Teigha.GeometryCurve3d
- planeNormal
- Type: Teigha.GeometryVector3d
- offsetDistance
- Type: SystemDouble
See Also