TransactionAddNewlyCreatedDBObject Method

Adds a newly created database record object.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public virtual void AddNewlyCreatedDBObject(
        DBObject obj,
        bool add
)

Parameters

obj
Type: Teigha.DatabaseServicesDBObject
[in] Object to add or remove.
add
Type: SystemBoolean
[in] Flag that specifies whether to add or remove the object.
Remarks
The obj parameter must correspond to a newly created object that has never been closed. The object also must be a database resident (in other words, added to a database and has an object identifier). The add and remove operations are performed on the top transaction object.
See Also

©  Bricsys NV. All rights reserved.