Transaction Class

This .NET class wraps the OdTransaction class. Transactions help to extend the limits of operations performed on an object and eliminate conflict errors.
Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public class Transaction : RXObject

The Transaction type exposes the following members.

Constructors
  Name Description
Protected method Transaction
Initializes a new instance of the Transaction class
Top
Properties
  Name Description
Public property TransactionManager
Represents the transaction manager associated with this transaction.
Top
Methods
  Name Description
Public method Abort
Aborts the currently open transaction. This method initiates a rollback of all changes to objects since the start of the transaction.
Public method AddNewlyCreatedDBObject
Adds a newly created database record object.
Public method Commit
Commits the changes made in all objects opened during the transaction, and then closes them.
Protected method DeleteUnmanagedObject (Overrides RXObjectDeleteUnmanagedObject.)
Public method GetAllObjects
Retrieves all objects that are open in this transaction.
Public method GetObject(ObjectId, OpenMode)
Calls the OpenObject() method of the underlaying C++ object, for the passed id within the specified open mode.
Public method GetObject(ObjectId, OpenMode, Boolean)
Calls the OpenObject() method of the underlaying C++ object for the passed id within the specified open mode.
Public method GetObject(ObjectId, OpenMode, Boolean, Boolean)
Calls the OpenObject() method of the underlaying C++ object for the passed id within the specified open mode.
Top
See Also

©  Bricsys NV. All rights reserved.