SubentityOverruleGetSubentPathsAtGsMarker Method
|
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public virtual FullSubentityPath[] GetSubentPathsAtGsMarker(
Entity entity,
SubentityType t,
IntPtr gsMark,
Point3d pickPoint,
Matrix3d viewXform,
ObjectId[] entAndInsertStack
)
Public Overridable Function GetSubentPathsAtGsMarker (
entity As Entity,
t As SubentityType,
gsMark As IntPtr,
pickPoint As Point3d,
viewXform As Matrix3d,
entAndInsertStack As ObjectId()
) As FullSubentityPath()
public:
virtual array<FullSubentityPath>^ GetSubentPathsAtGsMarker(
Entity^ entity,
SubentityType t,
IntPtr gsMark,
Point3d pickPoint,
Matrix3d viewXform,
array<ObjectId>^ entAndInsertStack
)
abstract GetSubentPathsAtGsMarker :
entity : Entity *
t : SubentityType *
gsMark : IntPtr *
pickPoint : Point3d *
viewXform : Matrix3d *
entAndInsertStack : ObjectId[] -> FullSubentityPath[]
override GetSubentPathsAtGsMarker :
entity : Entity *
t : SubentityType *
gsMark : IntPtr *
pickPoint : Point3d *
viewXform : Matrix3d *
entAndInsertStack : ObjectId[] -> FullSubentityPath[]
Parameters
- entity
- Type: Teigha.DatabaseServicesEntity
- t
- Type: Teigha.DatabaseServicesSubentityType
- gsMark
- Type: SystemIntPtr
- pickPoint
- Type: Teigha.GeometryPoint3d
- viewXform
- Type: Teigha.GeometryMatrix3d
- entAndInsertStack
- Type: Teigha.DatabaseServicesObjectId
Return Value
Type:
FullSubentityPath
See Also