SubentityOverrule Class |
The SubentityOverrule type exposes the following members.
Name | Description | |
---|---|---|
![]() |
SubentityOverrule |
Initializes a new instance of the SubentityOverrule class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() |
AddSubentPaths | |
![]() |
Clone | (Inherited from RXObject.) |
![]() |
CompareTo | (Inherited from RXObject.) |
![]() |
CopyFrom | (Inherited from RXObject.) |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteSubentPaths | |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetCompoundObjectTransform | |
![]() |
GetGripPointsAtSubentPath | |
![]() |
GetGsMarkersAtSubentPath | |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetRXClass | (Inherited from RXObject.) |
![]() |
GetSubentClassId | |
![]() |
GetSubentPathGeomExtents | |
![]() |
GetSubentPathsAtGsMarker | |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IsApplicable | (Inherited from Overrule.) |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
MoveGripPointsAtSubentPaths | |
![]() |
OnSubentGripStatusChanged | |
![]() |
QueryX | (Inherited from RXObject.) |
![]() |
SetCustomFilter | (Overrides OverruleSetCustomFilter.) |
![]() |
SetExtensionDictionaryEntryFilter | (Overrides OverruleSetExtensionDictionaryEntryFilter(String).) |
![]() |
SetIdFilter | (Overrides OverruleSetIdFilter(ObjectId).) |
![]() |
SetNoFilter | (Overrides OverruleSetNoFilter.) |
![]() |
SetXDataFilter | (Overrides OverruleSetXDataFilter(String).) |
![]() |
SubentPtr | |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
TransformSubentPathsBy | |
![]() |
X | (Inherited from RXObject.) |
© Bricsys NV. All rights reserved. |