Cone Constructor (Double, Double, Point3d, Double, Vector3d)

Constructor for the Cone class. Creates a cone with the specified cosine and sine angles, base point, base radius and axis of symmetry.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public Cone(
        double cosineAngle,
        double sineAngle,
        Point3d baseOrigin,
        double baseRadius,
        Vector3d axisOfSymmetry
)

Parameters

cosineAngle
Type: SystemDouble
[in] Cosine angle.
sineAngle
Type: SystemDouble
[in] Sine angle.
baseOrigin
Type: Teigha.GeometryPoint3d
[in] Base origin.
baseRadius
Type: SystemDouble
[in] Base radius.
axisOfSymmetry
Type: Teigha.GeometryVector3d
[in] Axis of symmetry.
See Also

©  Bricsys NV. All rights reserved.