Cone Class |
The Cone type exposes the following members.
Name | Description | |
---|---|---|
![]() |
Cone |
Default constructor for the Cone class.
Creates a cone with half angle of 45°, a reference axis of
(1,0,0), a baseOrigin of (0,0,0), an axisOfSymmetry of (0,1,0), and
a base radius of 2.0.
|
![]() |
Cone(Double, Double, Point3d, Double, Vector3d) |
Constructor for the Cone class. Creates a cone
with the specified cosine and sine angles, base point, base radius
and axis of symmetry.
|
![]() |
Cone(Double, Double, Point3d, Double, Vector3d, Vector3d, Interval, Double, Double) |
Constructor for the Cone class. Creates a cone
with the specified cosine and sine angles, base point, base radius,
axis of symmetry, height, and start and end angles of
rotation.
|
Name | Description | |
---|---|---|
![]() |
Apex | |
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
AxisOfSymmetry | |
![]() |
BaseCenter | |
![]() |
BaseRadius | |
![]() |
HalfAngle | |
![]() |
Height | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
IsNormalReversed | (Inherited from Surface.) |
![]() |
IsOuterNormal | |
![]() |
ReferenceAxis | |
![]() |
ReverseNormal | (Inherited from Surface.) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from Entity3d.) |
![]() |
ClosestPointTo(Point3d) | (Inherited from Surface.) |
![]() |
ClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.) |
![]() ![]() |
Create |
Creates a Cone object based on the passed
pointer.
|
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
DistanceTo(Point3d) | (Inherited from Surface.) |
![]() |
DistanceTo(Point3d, Tolerance) | (Inherited from Surface.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
EvaluatePoint | (Inherited from Surface.) |
![]() |
GetAngles |
Retrieves angles of rotation for this
cone.
|
![]() |
GetClosestPointTo(Point3d) | (Inherited from Surface.) |
![]() |
GetClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.) |
![]() |
GetEnvelope | (Inherited from Surface.) |
![]() |
GetHalfAngles |
Retrieves half angles that define this cone.
Absolute values of angles are retrieved (i.e. any signs are
dropped).
|
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetHeightAt |
Retrieves the height of this cone
corresponding to the specified position on the U-axis.
|
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IntersectWith(LinearEntity3d) |
Retrieves intersection points between this
cone and the passed linear entity.
|
![]() |
IntersectWith(LinearEntity3d, Tolerance) |
Retrieves intersection points between this
cone and the passed linear entity. Calculations are performed
within the specified tolerance.
|
![]() |
IsClosed |
Checks whether the base of this cone is a full
circle.
|
![]() |
IsClosed(Tolerance) |
Checks whether the base of this cone is a full
circle within the specified tolerance.
|
![]() |
IsClosedInU | (Inherited from Surface.) |
![]() |
IsClosedInU(Tolerance) | (Inherited from Surface.) |
![]() |
IsClosedInV | (Inherited from Surface.) |
![]() |
IsClosedInV(Tolerance) | (Inherited from Surface.) |
![]() |
IsEqualTo(Entity3d) | (Inherited from Entity3d.) |
![]() |
IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.) |
![]() |
IsOn(Point3d) | (Inherited from Entity3d.) |
![]() |
IsOn(Point3d, Tolerance) | (Inherited from Entity3d.) |
![]() |
IsOn(Point3d, Point2d) | (Inherited from Surface.) |
![]() |
IsOn(Point3d, Point2d, Tolerance) | (Inherited from Surface.) |
![]() |
Mirror | (Inherited from Entity3d.) |
![]() |
ParameterOf(Point3d) | (Inherited from Surface.) |
![]() |
ParameterOf(Point3d, Tolerance) | (Inherited from Surface.) |
![]() |
RotateBy | (Inherited from Entity3d.) |
![]() |
ScaleBy | (Inherited from Entity3d.) |
![]() |
Set(Double, Double, Point3d, Double, Vector3d) |
Sets the parameters for this cone according to
the arguments.
|
![]() |
Set(Double, Double, Point3d, Double, Vector3d, Vector3d, Interval, Double, Double) |
Sets the parameters for this cone according to
the arguments.
|
![]() |
SetAngles |
Sets the start and end angles of rotation for
this cone.
|
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
TransformBy | (Inherited from Entity3d.) |
![]() |
TranslateBy | (Inherited from Entity3d.) |
© Bricsys NV. All rights reserved. |