Curve3dGetTrimmedOffset Method (Double, Vector3d,
OffsetCurveExtensionType, Tolerance)
|
Receives one or more offset curves that
represent the trimmed offset of the curve.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Curve3d[] GetTrimmedOffset(
double distance,
Vector3d planeNormal,
OffsetCurveExtensionType extensionType,
Tolerance tolerance
)
Public Function GetTrimmedOffset (
distance As Double,
planeNormal As Vector3d,
extensionType As OffsetCurveExtensionType,
tolerance As Tolerance
) As Curve3d()
public:
array<Curve3d^>^ GetTrimmedOffset(
double distance,
Vector3d planeNormal,
OffsetCurveExtensionType extensionType,
Tolerance tolerance
)
member GetTrimmedOffset :
distance : float *
planeNormal : Vector3d *
extensionType : OffsetCurveExtensionType *
tolerance : Tolerance -> Curve3d[]
Parameters
- distance
- Type: SystemDouble
[in] Offset distance.
- planeNormal
- Type: Teigha.GeometryVector3d
[in] A normal to the plane of this curve.
- extensionType
- Type: Teigha.GeometryOffsetCurveExtensionType
[in] Determines how the offset curve will be extended at points of
C1 discontinuity.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
Curve3d
Array that stores offset curves.
See Also