Curve3dGetSamplePoints Method (Double, Double, Double)
|
Retrieves specified arrays of sample points
along this curve and their parameter values.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public PointOnCurve3d[] GetSamplePoints(
double fromParameter,
double toParameter,
double chordHeight
)
Public Function GetSamplePoints (
fromParameter As Double,
toParameter As Double,
chordHeight As Double
) As PointOnCurve3d()
public:
array<PointOnCurve3d^>^ GetSamplePoints(
double fromParameter,
double toParameter,
double chordHeight
)
member GetSamplePoints :
fromParameter : float *
toParameter : float *
chordHeight : float -> PointOnCurve3d[]
Parameters
- fromParameter
- Type: SystemDouble
[in] First parameter value that represents the start of the
interval.
- toParameter
- Type: SystemDouble
[in] Second parameter value that represents the end of the
interval.
- chordHeight
- Type: SystemDouble
[in] Approximation spacing (step) along a parametric range.
Return Value
Type:
PointOnCurve3d
Array of sample points.
See Also