BoundBlock3d Constructor (Point3d, Vector3d, Vector3d,
Vector3d)
|
Constructor for the BoundBlock3d class.
Constructs a bounding block with the specified base point.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public BoundBlock3d(
Point3d point1,
Vector3d dir1,
Vector3d dir2,
Vector3d dir3
)
Public Sub New (
point1 As Point3d,
dir1 As Vector3d,
dir2 As Vector3d,
dir3 As Vector3d
)
public:
BoundBlock3d(
Point3d point1,
Vector3d dir1,
Vector3d dir2,
Vector3d dir3
)
new :
point1 : Point3d *
dir1 : Vector3d *
dir2 : Vector3d *
dir3 : Vector3d -> BoundBlock3d
Parameters
- point1
- Type: Teigha.GeometryPoint3d
[in] Base of a parallelogram bounding block.
- dir1
- Type: Teigha.GeometryVector3d
[in] First side of a parallelogram bounding block.
- dir2
- Type: Teigha.GeometryVector3d
[in] Second side of a parallelogram bounding block.
- dir3
- Type: Teigha.GeometryVector3d
[in] Third side of a parallelogram bounding block.
See Also