BoundBlock3d Class |
The BoundBlock3d type exposes the following members.
Name | Description | |
---|---|---|
![]() |
BoundBlock3d |
Default constructor for the BoundBlock3d
class. Constructs a bounding block with minimum and maximum points
at the coordinate system origin.
|
![]() |
BoundBlock3d(Point3d, Vector3d, Vector3d, Vector3d) |
Constructor for the BoundBlock3d class.
Constructs a bounding block with the specified base point.
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
BasePoint | |
![]() |
Direction1 | |
![]() |
Direction2 | |
![]() |
Direction3 | |
![]() |
IsBox | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from Entity3d.) |
![]() |
Contains |
Checks whether this bounding block contains
the specified point.
|
![]() ![]() |
Create |
Creates a BoundBlock3d object based on the
passed pointer.
|
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Extend |
Extends the bounding block to contain the
specified point.
|
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetMaximumPoint |
Retrieves the maximum point of this bounding
block.
|
![]() |
GetMinimumPoint |
Retrieves the minimum point of this bounding
block.
|
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IsDisjoint |
Checks if this bounding block does not
intersect with the specified bounding block.
|
![]() |
IsEqualTo(Entity3d) | (Inherited from Entity3d.) |
![]() |
IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.) |
![]() |
IsOn(Point3d) | (Inherited from Entity3d.) |
![]() |
IsOn(Point3d, Tolerance) | (Inherited from Entity3d.) |
![]() |
Mirror | (Inherited from Entity3d.) |
![]() |
RotateBy | (Inherited from Entity3d.) |
![]() |
ScaleBy | (Inherited from Entity3d.) |
![]() |
Set(Point3d, Point3d) |
Sets the minimum and maximum points of the
bounding block.
|
![]() |
Set(Point3d, Vector3d, Vector3d, Vector3d) |
Sets the base point and sides of a
parallelogram bounding block.
|
![]() |
Swell |
Moves the walls of this bounding block by the
specified distance.
|
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
TransformBy |
Transforms this bounding block by the
specified 3D matrix.
|
![]() |
TranslateBy | (Inherited from Entity3d.) |
© Bricsys NV. All rights reserved. |