ColorFromColorIndex Method
|
Returns new color object by color method and
index.
Namespace: Teigha.Colors
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public static Color FromColorIndex(
ColorMethod colorMethod,
short colorIndex
)
Public Shared Function FromColorIndex (
colorMethod As ColorMethod,
colorIndex As Short
) As Color
public:
static Color^ FromColorIndex(
ColorMethod colorMethod,
short colorIndex
)
static member FromColorIndex :
colorMethod : ColorMethod *
colorIndex : int16 -> Color
Parameters
- colorMethod
- Type: Teigha.ColorsColorMethod
ColorMethod object.
- colorIndex
- Type: SystemInt16
Color index (ACI).
Return Value
Type:
Color
New color object.
Remarks
colorIndex must be one of the following:
Value |
Description |
0 |
ByBlock |
7 |
Foreground color |
256 |
ByLayer |
1 |
Red |
2 |
Yellow |
3 |
Green |
4 |
Cyan |
5 |
Blue |
6 |
Magenta |
8-255 |
Defined by display device |
257 |
No color |
See Also