Color Class

This .NET class wraps the OdCmColor class.
Inheritance Hierarchy
Namespace:  Teigha.Colors
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class Color : DisposableWrapper, 
        IComparable, ICloneable

The Color type exposes the following members.

Constructors
  Name Description
Public method Color
Default constructor.
Top
Properties
  Name Description
Public property Blue
Gets the blue component of the current color.
Public property BookName
Gets the book name.
Public property ColorIndex
Gets the color index.
Public property ColorMethod
Gets the color method.
Public property ColorName
Gets the color name.
Public property ColorNameForDisplay
Gets the color name for the display.
Public property ColorValue
Gets the color value.
Public property Description
Gets the description.
Public property DictionaryKey
Gets the dictionary key.
Public property DictionaryKeyLength
Gets the dictionary key length.
Public property EntityColor
Gets the entity color.
Public property Explanation
Gets the explanation.
Public property Green
Gets the green component of the current color.
Public property HasBookName
Gets if there is a book name.
Public property HasColorName
Gets if there is a color name.
Public property IsByAci
Gets if the color method for this object is ColorMethod.ByAci.
Public property IsByBlock
Gets if the color method for this object is ColorMethod.ByBlock or the color method is ColorMethod.ByAci and the ACI is ByBlock.
Public property IsByColor
Gets if the color method for this object is ColorMethod.ByColor.
Public property IsByLayer
Gets if the color method for this object is ColorMethod.ByLayer or the color method is ColorMethod.ByAci and the ACI is ByLayer.
Public property IsByPen
Gets if the color method for this object is ColorMethod.ByPen.
Public property IsForeground
Gets if the color is foreground color or the color method is ColorMethod.ByAci and the ACI is Foreground.
Public property IsNone
Gets if there is no color.
Public property PenIndex
Gets the pen index.
Public property Red
Gets the red component of the current color.
Top
Methods
  Name Description
Public method Audit
Performs an audit operation on this object.
Public method Clone
Creates a clone of the object.
Public method CompareTo
Makes comparison operation and returns the result.
Public methodStatic member DwgIn
Creates a new Color object, reads the DWG format data of this object from the specified file and returns it.
Public method DwgOut
Writes the DWG format data of this object to the specified filer.
Public methodStatic member DxfIn
Public method DxfOut
Public method Equals
Returns the truthness of the objects comparison operation.
(Overrides DisposableWrapperEquals(Object).)
Public methodStatic member FromColor
Returns new color object by color value.
Public methodStatic member FromColorIndex
Returns new color object by color method and index.
Public methodStatic member FromDictionaryName
Returns new color object using a dictionary name.
Public methodStatic member FromEntityColor
Returns new color object from EntityColor.
Public methodStatic member FromNames
Returns new color object using color name and book name.
Public methodStatic member FromRgb
Returns new color object by RGB model.
Public method GetHashCode
Returns hash code for this object.
(Overrides DisposableWrapperGetHashCode.)
Protected method ICloneable_Clone
Protected method IComparable_CompareTo
Public method ToString
Returns a string representation of this Object.
(Overrides ObjectToString.)
Public method ToString(IFormatProvider)
Returns a string representation of this Object depending on UI culture defined by provider
Top
Operators
  Name Description
Public operatorStatic member Equality
Equal-To Operator
Public operatorStatic member GreaterThan
More-Than Operator
Public operatorStatic member Inequality
Not-Equal-To Operator
Public operatorStatic member LessThan
Less-Than Operator
Top
See Also

©  Bricsys NV. All rights reserved.