Viewport Class |
The Viewport type exposes the following members.
Name | Description | |
---|---|---|
![]() |
AcadWindowId | |
![]() |
![]() |
CameraLocation | |
![]() |
CameraTarget | |
![]() |
CameraUpVector | |
![]() |
DeviceContextViewportCorners | |
![]() |
EyeToModelTransform | |
![]() |
EyeToWorldTransform | |
![]() |
FrontAndBackClipping | |
![]() |
![]() |
IsPerspective | |
![]() |
LinetypeGenerationCriteria | |
![]() |
LinetypeScaleMultiplier | |
![]() |
ModelToEyeTransform | |
![]() |
![]() |
ViewDirection | |
![]() |
ViewportId | |
![]() |
WorldToEyeTransform |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
![]() |
![]() |
![]() |
![]() |
DoInversePerspective | |
![]() |
DoPerspective | |
![]() |
![]() |
![]() |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
![]() |
GetNumPixelsInUnitSquare | |
![]() |
![]() |
GetType |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
![]() |
![]() |
MemberwiseClone(Boolean) |
![]() |
![]() |
ToString |
Returns a string that represents the current
![]() |
© Bricsys NV. All rights reserved. |