DisposableWrapper Class |
The DisposableWrapper type exposes the following members.
Name | Description | |
---|---|---|
![]() |
DisposableWrapper |
Initializes a new instance of the DisposableWrapper class
|
![]() |
DisposableWrapper(IntPtr, Boolean) |
Initializes a new instance of the DisposableWrapper class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | |
![]() |
IsDisposed | |
![]() |
UnmanagedObject |
Name | Description | |
---|---|---|
![]() ![]() |
Create | |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteUnmanagedObject | |
![]() |
Dispose |
Releases all resources used by the
DisposableWrapper
|
![]() |
Dispose(Boolean) |
Releases the unmanaged resources used by the
DisposableWrapper and optionally
releases the managed resources
|
![]() |
Equals | (Overrides ObjectEquals(Object).) |
![]() |
Finalize | (Overrides ObjectFinalize.) |
![]() |
GetHashCode | (Overrides ObjectGetHashCode.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
Name | Description | |
---|---|---|
![]() ![]() |
Equality | |
![]() ![]() |
Inequality |
© Bricsys NV. All rights reserved. |