EllipticalCylinderSet Method (Double, Double, Point3d, Vector3d, Vector3d,
Interval, Double, Double)
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void Set(
double minorRadius,
double majorRadius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d referenceAxis,
Interval height,
double startAngle,
double endAngle
)
Public Sub Set (
minorRadius As Double,
majorRadius As Double,
origin As Point3d,
axisOfSymmetry As Vector3d,
referenceAxis As Vector3d,
height As Interval,
startAngle As Double,
endAngle As Double
)
public:
void Set(
double minorRadius,
double majorRadius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d referenceAxis,
Interval^ height,
double startAngle,
double endAngle
)
member Set :
minorRadius : float *
majorRadius : float *
origin : Point3d *
axisOfSymmetry : Vector3d *
referenceAxis : Vector3d *
height : Interval *
startAngle : float *
endAngle : float -> unit
Parameters
- minorRadius
- Type: SystemDouble
- majorRadius
- Type: SystemDouble
- origin
- Type: Teigha.GeometryPoint3d
- axisOfSymmetry
- Type: Teigha.GeometryVector3d
- referenceAxis
- Type: Teigha.GeometryVector3d
- height
- Type: Teigha.GeometryInterval
- startAngle
- Type: SystemDouble
- endAngle
- Type: SystemDouble
See Also