Interval Class |
The Interval type exposes the following members.
Name | Description | |
---|---|---|
![]() |
Interval(Double) |
Initializes a new instance of the Interval class
|
![]() |
Interval(Interval) |
Initializes a new instance of the Interval class
|
![]() |
Interval(Double, Double, Double) |
Initializes a new instance of the Interval class
|
![]() |
Interval(Int32, Double, Double) |
Initializes a new instance of the Interval class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
Element | |
![]() |
IsBounded | |
![]() |
IsBoundedAbove | |
![]() |
IsBoundedBelow | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
IsSingleton | |
![]() |
IsUnbounded | |
![]() |
Length | |
![]() |
LowerBound | |
![]() |
Tolerance | |
![]() ![]() |
Unbounded | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
![]() |
UpperBound |
Name | Description | |
---|---|---|
![]() |
Contains(Double) | |
![]() |
Contains(Interval) | |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
GetBounds | |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetMerge | |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IntersectWith | |
![]() |
IsContinuousAtUpper | |
![]() |
IsDisjoint | |
![]() |
IsEqualAtLower(Double) | |
![]() |
IsEqualAtLower(Interval) | |
![]() |
IsEqualAtUpper(Double) | |
![]() |
IsEqualAtUpper(Interval) | |
![]() |
IsOverlapAtUpper | |
![]() |
IsPeriodicallyOn | |
![]() |
Subtract | |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
© Bricsys NV. All rights reserved. |