Curve3dGetClosestPointTo Method (Point3d, Tolerance)
|
Retrieves the closest point on this curve to
the specified point within a specified tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public PointOnCurve3d GetClosestPointTo(
Point3d point,
Tolerance tolerance
)
Public Function GetClosestPointTo (
point As Point3d,
tolerance As Tolerance
) As PointOnCurve3d
public:
PointOnCurve3d^ GetClosestPointTo(
Point3d point,
Tolerance tolerance
)
member GetClosestPointTo :
point : Point3d *
tolerance : Tolerance -> PointOnCurve3d
Parameters
- point
- Type: Teigha.GeometryPoint3d
[in] Point to which the closest point is calculated.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
PointOnCurve3d
The closest point on this curve.
See Also