EntityBoundingBoxIntersectWith Method (Entity, Intersect, Plane,
Point3dCollection, IntPtr, IntPtr)
|
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void BoundingBoxIntersectWith(
Entity entityPointer,
Intersect intersectType,
Plane projectionPlane,
Point3dCollection points,
IntPtr thisGraphicSystemMarker,
IntPtr otherGraphicSystemMarker
)
Public Sub BoundingBoxIntersectWith (
entityPointer As Entity,
intersectType As Intersect,
projectionPlane As Plane,
points As Point3dCollection,
thisGraphicSystemMarker As IntPtr,
otherGraphicSystemMarker As IntPtr
)
public:
void BoundingBoxIntersectWith(
Entity^ entityPointer,
Intersect intersectType,
Plane^ projectionPlane,
Point3dCollection^ points,
IntPtr thisGraphicSystemMarker,
IntPtr otherGraphicSystemMarker
)
member BoundingBoxIntersectWith :
entityPointer : Entity *
intersectType : Intersect *
projectionPlane : Plane *
points : Point3dCollection *
thisGraphicSystemMarker : IntPtr *
otherGraphicSystemMarker : IntPtr -> unit
Parameters
- entityPointer
- Type: Teigha.DatabaseServicesEntity
- intersectType
- Type: Teigha.DatabaseServicesIntersect
- projectionPlane
- Type: Teigha.GeometryPlane
- points
- Type: Teigha.GeometryPoint3dCollection
- thisGraphicSystemMarker
- Type: SystemIntPtr
- otherGraphicSystemMarker
- Type: SystemIntPtr
See Also