ConeSet Method (Double, Double, Point3d, Double,
Vector3d)
|
Sets the parameters for this cone according to
the arguments.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void Set(
double cosineAngle,
double sineAngle,
Point3d baseCenter,
double baseRadius,
Vector3d axisOfSymmetry
)
Public Sub Set (
cosineAngle As Double,
sineAngle As Double,
baseCenter As Point3d,
baseRadius As Double,
axisOfSymmetry As Vector3d
)
public:
void Set(
double cosineAngle,
double sineAngle,
Point3d baseCenter,
double baseRadius,
Vector3d axisOfSymmetry
)
member Set :
cosineAngle : float *
sineAngle : float *
baseCenter : Point3d *
baseRadius : float *
axisOfSymmetry : Vector3d -> unit
Parameters
- cosineAngle
- Type: SystemDouble
[in] The cosine of the angle between the generating line and the
axis of symmetry.
- sineAngle
- Type: SystemDouble
[in] The sine of the angle between the generating line and the axis
of symmetry.
- baseCenter
- Type: Teigha.GeometryPoint3d
[in] Center of the base.
- baseRadius
- Type: SystemDouble
[in] Radius of the base.
- axisOfSymmetry
- Type: Teigha.GeometryVector3d
[in] Axis of symmetry (rotation).
See Also