Curve3dIsPlanar Method (Plane, Tolerance)

Checks whether this curve is planar within a specified tolerance. If the curve is a line, this function returns an arbitrary plane that contains the line. The plane parameter contains meaningful data only if this function returns a value of true.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public bool IsPlanar(
        out Plane plane,
        Tolerance tolerance
)

Parameters

plane
Type: Teigha.GeometryPlane
[out] Plane on which this curve lies if it is planar.
tolerance
Type: Teigha.GeometryTolerance
[in] Geometric tolerance.

Return Value

Type: Boolean
true if this curve is planar, false otherwise.
See Also

©  Bricsys NV. All rights reserved.