AssocEvaluationCallbackBeginActionEvaluationUsingObject Method

Initiates action evaluation. The action informs that it will perform read and write operations on the object represented by objectId. The action uses this callback just before it opens the object for read or write. Currently not implemented.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public abstract void BeginActionEvaluationUsingObject(
        AssocAction pAction,
        ObjectId objectId,
        bool objectIsGoingToBeUsed,
        bool objectIsGoingToBeModified,
        DBObject substituteObject
)

Parameters

pAction
Type: Teigha.DatabaseServicesAssocAction
[in] The action to be evaluated.
objectId
Type: Teigha.DatabaseServicesObjectId
[in] The object identifier that is going to be used or modified by the action.
objectIsGoingToBeUsed
Type: SystemBoolean
[in] A flag that specifies whether object content should be used.
objectIsGoingToBeModified
Type: SystemBoolean
[in] A flag that specifies whether object content should be modified.
substituteObject
Type: Teigha.DatabaseServicesDBObject
[out] An object that is optionally provided by the client code. The client code does not have to assign a value to this output argument.
See Also

©  Bricsys NV. All rights reserved.