TinSurfaceBreakline Class |
The TinSurfaceBreakline type exposes the following members.
Name | Description | |
---|---|---|
![]() |
TinSurfaceBreakline(TinBreaklineType) |
Initializes a new instance of the TinSurfaceBreakline class
|
![]() |
TinSurfaceBreakline(TinSurfaceBreakline) |
Initializes a new instance of the TinSurfaceBreakline class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
BreaklineType | |
![]() |
ConstraintId | (Inherited from TinSurfaceConstraint.) |
![]() |
ConstraintType | (Inherited from TinSurfaceConstraint.) |
![]() |
Data | (Inherited from TinSurfaceConstraint.) |
![]() |
IntersectionElevation | |
![]() |
IsDbResident | (Inherited from TinSurfaceConstraint.) |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
MidOrdinateDistance | (Inherited from TinSurfaceConstraint.) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteUnmanagedObject | (Inherited from TinSurfaceConstraint.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
SetData(UInt64, Point3dCollection) | (Inherited from TinSurfaceConstraint.) |
![]() |
SetData(ObjectId, Double) | (Inherited from TinSurfaceConstraint.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
© Bricsys NV. All rights reserved. |