Curve3dGetSamplePoints Method (Int32)
|
Retrieves an array of sample points along this
curve.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public PointOnCurve3d[] GetSamplePoints(
int numSample
)
Public Function GetSamplePoints (
numSample As Integer
) As PointOnCurve3d()
public:
array<PointOnCurve3d^>^ GetSamplePoints(
int numSample
)
member GetSamplePoints :
numSample : int -> PointOnCurve3d[]
Parameters
- numSample
- Type: SystemInt32
[in] Quantity of sample points.
Return Value
Type:
PointOnCurve3d
Array of sample points.
Remarks
For example, if
parametric range of this curve is [0,2] and the numSample is 5, the retrieved points correspond to
the following parametric values: 0, 0.5, 1, 1.5, 2.
See Also