Transparency Structure

Wraps OdCmTransparency class. Implements Transparency objects, which provide transparency information about Drawable objects.
Namespace:  Teigha.Colors
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public struct Transparency

The Transparency type exposes the following members.

Constructors
  Name Description
Public method Transparency(Byte)
Builds an instance of the object using alpha value.
Public method Transparency(TransparencyMethod)
Builds an instance of the object using transparency method.
Top
Properties
  Name Description
Public property Alpha
Gets the alpha value for this object.
Public property IsByAlpha
Gets if the transparency method is ByAlpha
Public property IsByBlock
Gets if the transparency method is ByBlock
Public property IsByLayer
Gets if the transparency method is ByLayer
Public property IsClear
Gets if the transparency method for this Transparency object is ByALpha and alpha == 0.
Public property IsSolid
Gets if the transparency method for this Transparency object is ByALpha and alpha == 255.
Top
Methods
Operators
  Name Description
Public operatorStatic member Equality
Equal-To Operator
Public operatorStatic member Inequality
Not-Equal-To Operator
Top
See Also

©  Bricsys NV. All rights reserved.