Curve3dGetOrthoProjectEntity Method (Plane, Tolerance)
|
Retrieves the entity representing the curve's
orthogonal projection onto the projection plane.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Entity3d GetOrthoProjectEntity(
Plane projectionPlane,
Tolerance tolerance
)
Public Function GetOrthoProjectEntity (
projectionPlane As Plane,
tolerance As Tolerance
) As Entity3d
public:
Entity3d^ GetOrthoProjectEntity(
Plane^ projectionPlane,
Tolerance tolerance
)
member GetOrthoProjectEntity :
projectionPlane : Plane *
tolerance : Tolerance -> Entity3d
Parameters
- projectionPlane
- Type: Teigha.GeometryPlane
[in] Plane for the projection of the curve.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
Entity3d
A projected entity.
See Also