BIMLinearGeometry Class |
The BIMLinearGeometry type exposes the following members.
Name | Description | |
---|---|---|
![]() |
BIMLinearGeometry |
Initializes a new instance of the BIMLinearGeometry class
|
![]() |
BIMLinearGeometry(BIMLinearGeometry) |
Initializes a new instance of the BIMLinearGeometry class
|
![]() |
BIMLinearGeometry(ObjectId) |
Initializes a new instance of the BIMLinearGeometry class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteUnmanagedObject | (Overrides DisposableWrapperDeleteUnmanagedObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetAssignedProfile | |
![]() |
GetAxis | |
![]() |
GetClippingFaces | |
![]() |
GetExtrusionPath | |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetId | |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetProfile | |
![]() |
GetSideFaces | |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IsValid | |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
SetId | |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
© Bricsys NV. All rights reserved. |