Curve3dGetNormalPoint Method (Point3d, Tolerance)
|
Retrieves the point on this curve where normal
extends through the passed point within the specified
tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public PointOnCurve3d GetNormalPoint(
Point3d point,
Tolerance tolerance
)
Public Function GetNormalPoint (
point As Point3d,
tolerance As Tolerance
) As PointOnCurve3d
public:
PointOnCurve3d^ GetNormalPoint(
Point3d point,
Tolerance tolerance
)
member GetNormalPoint :
point : Point3d *
tolerance : Tolerance -> PointOnCurve3d
Parameters
- point
- Type: Teigha.GeometryPoint3d
[in] Point for which corresponding point on this curve is
retrieved.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
PointOnCurve3d
Point whose normal passes through the input point.
See Also